Back to CVE records
High 8.8Published May 12, 2026

CVE-2026-7474Nomad vulnerable to path traversal in dynamic host volume which may lead to code execution

Updated under an hour ago ()

Does this affect you?

It affects HashiCorp Nomad and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to code execution on the client host through a path traversal attack. This vulnerability (CVE-2026-7474) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.

CVSS
8.8 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-22
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
HashiCorp
NVD analysis
Deferred
Record last updated
May 12, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
HashiCorp Nomad
hashicorp:nomad (from the name)
from 1.10.0 before 2.0.1
CNA record
HashiCorp Nomad Enterprise
hashicorp:nomad_enterprise (from the name)
from 1.10.0 before 2.0.1; fixed at 1.10.11, fixed at 1.11.5
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.