Back to CVE records
High 7.3Published Apr 30, 2026

CVE-2026-7505nextlevelbuilder GoClaw/GoClaw Lite RPC improper authorization

Updated under an hour ago ()

Does this affect you?

It affects nextlevelbuilder GoClaw and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A flaw has been found in nextlevelbuilder GoClaw and GoClaw Lite up to 3.8.5. This affects an unknown function of the component RPC Handler. This manipulation causes improper authorization. The attack may be initiated remotely. The exploit has been published and may be used. Upgrading to version 3.9.0 mitigates this issue. Patch name: 406022e79f4a18b3070a446712080571eff11e30. You should upgrade the affected component.

CVSS
7.3 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
Weakness (CWE)
CWE-285, CWE-266
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulDB
NVD analysis
Deferred
Record last updated
May 1, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
nextlevelbuilder GoClaw
nextlevelbuilder:goclaw (from the name)
3.8.0; 3.8.1; 3.8.2; 3.8.3; 3.8.4; 3.8.5; 3.9.0 not affected
CNA record
nextlevelbuilder GoClaw Lite
nextlevelbuilder:goclaw_lite (from the name)
3.8.0; 3.8.1; 3.8.2; 3.8.3; 3.8.4; 3.8.5; 3.9.0 not affected
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.