Back to CVE records
High 7.3Published May 4, 2026

CVE-2026-7736osrg GoBGP mrt.go parseRibEntry integer underflow

Updated under an hour ago ()

Does this affect you?

It affects osrg GoBGP. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.

CVSS
7.3 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
Weakness (CWE)
CWE-191, CWE-189
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulDB
NVD analysis
Analyzed
Record last updated
May 4, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
osrg GoBGP
osrg:gobgp
4.0; 4.1; 4.2; 4.3.0; 4.4.0 not affected
CNA record
osrg gobgp
osrg:gobgp
before 4.4.0
NVD

References

  • vdb-entry, technical-description, third-party-advisory
  • signature, permissions-required, vdb-entry
  • third-party-advisory, vdb-entry
  • patch
  • patch, product
  • product

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.