Back to CVE records
Low 3.3Published May 7, 2026

CVE-2026-8088OSGeo gdal GDapi.c GDfieldinfo out-of-bounds

Updated under an hour ago ()

Does this affect you?

It affects OSGeo gdal. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A weakness has been identified in OSGeo gdal up to 3.13.0dev-4. The affected element is the function GDfieldinfo of the file frmts/hdf4/hdf-eos/GDapi.c. Executing a manipulation can lead to out-of-bounds read. The attack needs to be launched locally. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.13.0RC1 is sufficient to fix this issue. This patch is called a791f70f8eaec540974ec989ca6fb00266b7646c. The affected component should be upgraded.

CVSS
3.3 LOW (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C
Weakness (CWE)
CWE-125, CWE-119
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulDB
NVD analysis
Analyzed
Record last updated
May 8, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
OSGeo gdal
osgeo:gdal
3.13.0dev-4; 3.13.0RC1 not affected
CNA record
osgeo gdal
osgeo:gdal
through 3.12.4; 3.13.0; 3.13.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.