Back to CVE records
Medium 5.3Published May 9, 2026

CVE-2026-8212OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow

Updated under an hour ago ()

Does this affect you?

It affects OSGeo gdal. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.

CVSS
5.3 MEDIUM (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
Weakness (CWE)
CWE-122, CWE-119
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulDB
NVD analysis
Analyzed
Record last updated
May 11, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
OSGeo gdal
osgeo:gdal
3.13.0dev-4; 3.13.0RC1 not affected
CNA record
osgeo gdal
osgeo:gdal
through 3.12.4; 3.13.0; 3.13.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.