CVE-2026-8804Cleartext Storage of Sensitive Information for Puppet Resource API
Updated under an hour ago ()
Does this affect you?
It affects Perforce Puppet Core and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Puppet resource_api (shipped in Puppet Core 8.x and Puppet Enterprise 2023.8.x and 2025.x) does not preserve the sensitive flag on parameters defined via the resource-api, causing values such as passwords to be stored in cleartext in the agent's local transaction state cache. Affected versions of the resource_api module include all versions between 1.5.0 - 1.9.1 and 2.0.0 The issue was fixed in puppet resource_api 1.9.2 and 2.0.1 released with Puppet Core 8.20.0 and PE 2023.8.10 & PE 2025.11.0.
- CVSS
- 6.7 MEDIUM (v4.0, CNA)CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:L
- Weakness (CWE)
- CWE-313, CWE-312
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- Perforce
- NVD analysis
- Awaiting Analysis
- Record last updated
- Jul 6, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Perforce Puppet Core perforce:puppet_core (from the name) | from 8.11.0 through 8.19.0; from 8.0.0 through 8.10.0; 8.20.0 not affected | CNA record |
Perforce Puppet Enterprise perforce:puppet_enterprise (from the name) | from 2023.8.0 through 2023.8.9; from 2025.0.0 through 2025.10.0; 2023.8.10 not affected; 2025.11.0 not affected | CNA record |
References
- https://portal.perforce.com/s/cve/a91Qi000003511lIAA/cve20268804-cleartext-storage-of-sensitive-information-for-puppet-resource-api
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.