Back to CVE records
High 7.3Published May 25, 2026

CVE-2026-9521fraillt bitsery std_smart_ptr.h loadFromSharedState improper validation of specified type of input

Updated under an hour ago ()

Does this affect you?

It affects fraillt bitsery. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A security vulnerability has been detected in fraillt bitsery up to 5.2.4. Affected is the function loadFromSharedState in the library include/bitsery/ext/std_smart_ptr.h. Such manipulation leads to improper validation of specified type of input. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 5.2.5 is able to address this issue. The name of the patch is 66d16516e24893bebc1c8af52bf2fe9ad0735061. Upgrading the affected component is advised.

CVSS
7.3 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
Weakness (CWE)
CWE-1287, CWE-20
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulDB
NVD analysis
Deferred
Record last updated
May 26, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
fraillt bitsery
fraillt:bitsery
5.2.0; 5.2.1; 5.2.2; 5.2.3; 5.2.4; 5.2.5 not affected
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.